Symptom
The sales order cannot perform ATP check with a sales kit product.
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the sales order).
- Edit the sales order XYZ and select the View All button.
- Go to the Items tab.
- Sales order document shows an error “Communication error during ATP Check” and the ATP is show grey.
Cause
The error occurs due to the inconsistency of the Requested Date maintained for the Kit Header and the Kit Items of the sales order.
At the item level of the sales order XYZ, you have added the sales kit product ABC (ABC represents the ID of the sales kit product).
Here you maintained a Requested Date for the Kit header, but no Requested Date or a different Requested date for the Kit Items which violates the Kit integrity.
Since you have maintained a different or no Requested Date for the Kit Items, the data become inconsistent and the system cannot perform ATP calculation.
Resolution
To correct the sales order, you must enter the same Requested Date you maintained in the Kit Header also for the Kit Items. You then have to perform availability check again and release the sales order.
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the sales order).
- Edit the sales order XYZ and select the View All button.
- Go to the Items tab.
- Select the line item with product ABC.
- Maintain the same Requested Date for all kit items as maintained in the kit header.
- Save the order.
- Release the order to the customer demand.
Keywords
KBA , AP-SLO , Sales Order Processing , How To