Symptom
Your requirement is to Migrate the Service Requests with the Description and Notes and the Author ID information. After importing Service Requests, the User importing the file is set as Author instead of the Business User which is provided with the import template.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Import Service Requests via Migration using the below steps:
- Go to Business Configuration work center
- Select Implementation Projects view or Overview
- Search and Open the activity Migration of Service Requests
- Select Migrate service requests using the migration tool
- Upload the Migration File
- Execute Migration for the respective Migration File with Migration Mode Add new records
Check the Service Ticket XXXXX as below:
- Go to Service workcenter
- Go to Tickets view
- Find the Ticket ID XXXXX and open the Ticket
- Go to the Overview tab
- In the Interactions, the From field contains the User Name PQR who imported the file instead of the Business User XYZ which is provided with the import template
(where XXXXX represents the Service Ticket ID,
PQR represents the User Name of the logged in User,
XYZ represents the Business User ID in the upload file)
Cause
In the migration file, in the tab Description and Notes, the Note Type field is blank.
Resolution
Fill the field Note Type with 10011, and the Author ID field with the Business Partner ID and migrate the file.
In the Service Ticket, we will now be able to see Notes in the name of the respective Author which you specified in the migration file.
Note:
1. While Note Type are 10008, 10011, 10022 and 10029, the Author is the Business User specified in the migration file.
2. While Note Type is 10007, first system looks for Author Name. If Author Name is not found, and Author UUID is found, then system tries to get the name from Business Partner using the Author UUID. If both are not present, then system checks the Creation Identity to get the person details.
3. While Note Type is 10004, first system looks for Last Changed Identity. Next, it looks for the Author Name. If the Author UUID is found, then system gets the name from the Business Partner using the Author UUID. If none is determined, system goes to the Creation Identity to get the person details.
(where 10004, 10007, 10008, 10011, 10022 and 10029 represents the Note Type)
Keywords
Author ID, Notes, Changed Identity, Last Changed Identity, Business Partner, Migration of Service Requests, Description and Notes, Note Type , KBA , author id , notes , changed identity , last changed identity , business partner , migration of service requests , note type , description and notes , LOD-CRM-SRP , Service Request Processing , How To