Symptom
The cancellation of a Project Invoice Request requires to be revoked in the system.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing Work Center.
- Go to the Project Invoicing View.
- Select the Project Invoice Requests Sub View.
- Search for the Project Invoice Request XYZ. (where XYZ represents the Project Invoice Request ID)
- The Project Invoice Request is displayed with one of the overall status: Release, Invoiced or Partially Invoiced.
- Cancel the Project Invoice Request XYZ.
The status of the Project Invoice Request XYZ is changed to Canceled. However it is not possible to revoke the cancelation of the document.
Cause
Once a Project Invoice Request is canceled, it is not possible to revoke the cancellation and this is expected behavior in SAP Business ByDesign.
One benefit of this feature is: If you want to avoid that the Project Invoice Requested is invoiced again by mistake (for example: by a user who is not aware that the related Customer Invoice has been canceled), then you can cancel the Project Invoice before canceling the Customer Invoice.
Resolution
Recommended actions for the following scenarios:
If the Customer Invoice does not exist: Create a new Project Invoice Request -> Create the Customer Invoice.
If the Customer Invoice exist: Cancel the existing Customer Invoice -> Create a new Project Invoice Request -> Create the Customer Invoice.
Keywords
project invoice request, customer invoice, canceled, revoke, cancellation , KBA , undo the cancellation of pir , undo cancel of project invoice request , project invoice request cancelled , project invoice request canceled , unable to re release pir , SRD-PRO-INV , Projects Customer Invoicing , AP-CI-CI , Customer Invoice , How To