Symptom
When you are creating a new Account you receive the warning message "Please enter a postal code" for some countries like India even though the field Postal Code is not defined mandatory by you for this country.
Reproducing the Issue
- Go to Customers work center.
- Go to Accounts view.
- Click on New.
- Fill all the mandatory details.
- In the Country field select India.
Even though the Postal Code field is not marked as mandatory you get a warning message "Please enter a postal code".
Cause
As per the new requirement legally, countries like India require the Postal Code as mandatory information in address, so system is changed accordingly due to the legal requirement.
Resolution
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select your respective implementation project.
- Click on the Open Activity List button.
- Navigate to the Fine-Tune tab.
- In the Show select All Activities.
- Select the fine tuning activity Countries.
- Click on the Add to Project button if it is not included.
- Open the fine tuning activity Countries.
- Click on the Edit Countries hyperlink.
- Click on the filter symbol and enter desired country and press enter.
- Select the Postal Attributes tab.
- You can deactivate the Street Address Postal Code Required indicator.
The Postal Code is then not mandatory when creating an address for an Account located in e.g. India.
Keywords
KBA , LOD-CRM-ACC , Account , How To