Symptom
When creating a new Account, the system displays the warning message:
"Please enter a postal code"
This occurs for certain countries (e.g., India) even though the Postal Code field has not been explicitly set as mandatory in the configuration for those countries.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Customers work center.
- Go to the Accounts view.
- Click on New to create a new account.
- Fill in all the mandatory fields.
- In the Country field, select India.
- Attempt to save the account.
Result:
A warning message is displayed: "Please enter a postal code", even though the Postal Code field is not marked as mandatory in the configuration.
Cause
As per the new requirement legally, countries like India require the Postal Code as mandatory information in address, so system is changed accordingly due to the legal requirement.
Resolution
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select your respective implementation project.
- Click on the Open Activity List button.
- Navigate to the Fine-Tune tab.
- In the Show select All Activities.
- Select the fine tuning activity Countries.
- Click on the Add to Project button if it is not included.
- Open the fine tuning activity Countries.
- Click on the Edit Countries hyperlink.
- Click on the filter symbol and enter desired country and press enter.
- Select the Postal Attributes tab.
- You can deactivate the Street Address Postal Code Required indicator.
The Postal Code is then not mandatory when creating an address for an Account located in e.g. India.
Keywords
Account, Postal Code, Customers, Warning Message, Fine-Tune, Countries, Symbol , KBA , LOD-CRM-ACC , Account , How To