Symptom
You are able to find records when you are searching for Individual Customers even when the ID's you are searching the Individual Customer with are incorrect and do not exist in the system.
Reproducing the Issue
- Go to Customers work center.
- Go to Individual Customers view.
- Search for an Individual Customer with ID say 12-34-AB.(where 12-34-AB is the ID of an Individual Customer which exists in the system).
- You are able to find the Individual Customer with ID 12-34-AB which is correct.
- Now search for Individual Customer with ID say 12-12-AB.(where 12-12-AB is the ID of an Individual Customer which does not exist in the system).
Youe expectation is that the result after search should be "No Records Found" as there is no Individual Customer with ID 12-12-AB.
But the search results in record where Individual Customer's ID is 12-34-AB.
Cause
The system uses HANA search criteria to perform search function which works as follows:
For example in this case the correct ID is 12-34-AB which exists in the system.
ID 12-34-AB will be broken down into 3 tokens.
token1 - 12
token2 - 34
token3 - AB
The search will be performed based on the below query:
select from id accounts where
(token1=12 or token2=12 or token3=12) AND
(token1=34 or token2=34 or token3=34) AND
(token1=AB or token2=AB or token3=AB)
Similarly when you input the incorrect ID 12-12-AB, it will be broken down into 3 tokens:
token1 - 12
token2 - 12
token3 - AB
and the search will be performed based on the below query:
select from id accounts where
(token1=12 or token2=12 or token3=12) AND
(token1=12 or token2=12 or token3=12) AND
(token1=AB or token2=AB or token3=AB)
Hence the result 12-34-AB is displayed when you search for 12-12-AB.
Resolution
This is the expected system behavior.
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , How To