SAP Knowledge Base Article - Public

2525818 - In an Account and Contact, the Phone Number Allows Alphanumeric Value

Symptom

In an Account and Contact, the Phone Number allows alphanumeric value.

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Contacts or Accounts view.
  3. Search for the ABC (where ABC is the Contact or Account Id) and open it.
  4. In the header for the field name Phone, enter an alphanumeric value for e.g. 123ABC45 and click on the Save button.

You can see the value 123ABC45 successfully saves for phone number.

Cause

We allow an alphanumeric value under phone/mobile number field. However, if it is special character (e.g. * , % , $ ), then those illegal characters are removed.

Resolution

This is an expected system behavior.

See Also

Please refer the blog for details :: https://blogs.sap.com/2016/07/28/sap-cloud-for-customer-phone-number-parsing-and-formatting/

Keywords

KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1708