Symptom
An Application error message comes up when you try to approve a workflow of a re-hire of an Inactive Employee.
Environment
Workflow
Reproducing the Issue
Proxy as an approver of the rehire workflow. Click Approve and you receive the Application error message.
errorId=d30acb0c-d0cb-4b26-a0b6-e5c4e87b8aaf, fingerprint=f753a6dad09fd2abe857005e8f50872fcdb948a1, timestamp=2017-08-21T05:59:01.435-0400, server=77pc4bcf67t, versionInfo=Release%3A%20b1705.1253985%0A%20%20%20%20%20%20Server%3A%2077pc4bcf67t%0A%20%20%20%20%20%20Timestamp%3A%202017-08-21T05%3A57%3A45.112-0400
or fingerprint=bd28d00f8f4eb3bdc271c87cb4753b8adef31582
Cause
This is because the inactive user has some Accrual Postings that are active on the Time off sections.
You will not be able to rehire this employee until all the active accrual postings of this employee are deleted.
Resolution
Please take the User ID of the inactive employee go to Manage Data -> Search for "Time Account" and paste the user ID into time account box, here you will get a return on all the postings that have been posted and are still active for the employee.
Please delete the accrual postings for this employee via take action>Permanently Delete Entry. Then approve the rehire of the inactive user and this will be successful.
Keywords
Accrual Postings, fingerprint=f753a6dad09fd2abe857005e8f50872fcdb948a1, Rehire Inactive Employee, Workflow, fingerprint=bd28d00f8f4eb3bdc271c87cb4753b8adef31582 , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-TIM , Time Off , Problem