SAP Knowledge Base Article - Public

2527195 - Unable to Assign Standard Roles to Users

Symptom

Administrator is not able to assign standard roles to users.

Environment

SAP S/4HANA Cloud Platform 1708

Reproducing the Issue

  1. Login to your Cloud Fiori Launchpad instance
  2. Using the Business Role App click on create from template in order to create a Business Role and assign it to the user
  3. You cannot assign actual Business Role template to the user

Cause

This is expected behavior.

Resolution

  • Customers cannot use Business Roles directly. We only deliver Business Role Templates, which a customer can use to create his own Business Roles
  • In order for the the customer to define his own restrictions, that is why customers cannot use directly the Business Role
  • Administrator needs make a copy from the Business Standard Template Role and assign it that to the user

Keywords

Unable to assign role, Application services business role , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 1705