Symptom
You are not able to activate the Price per Period indicator for a product in a contract.
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Contracts view.
- Click on the New button and select the Contract option.
- Enter all respective details.
- Navigate to the Items tab.
- Add a product.
- The Price per Period indicator is disabled and cannot be activated.
Cause
The product that you added to your contract under the tab Items has the item type Product – contract and therefore is a Material and not a Service. The field Price per Period can be activated in combination with an invoice schedule that was created for an item. This invoice schedule has to have the Schedule Type Period fixed price for a service which has a quantity unit which describes time (e.g. hours, working days etc.). Therefore, the Price per Period indicator can only be activated for the following item types:
- Service - fixed price
- Service - fixed price without actuals
- Expense - fixed price without actuals
- Entitlement - fixed price
- Entitlement - fixed price without actuals
You can find further information in the Help Centre document Invoice Schedule.
Resolution
This is the expected system behaviour.
Keywords
KBA , SRD-CRM-SEE , Service Entitlements , How To