Symptom
You want to Assign Tickets automatically to the creator of the Ticket.
Environment
- SAP Hybris Cloud For Customer
Reproducing the Issue
Prerequisite: You have created a workflow rule to set the creator of the Ticket as the Ticket owner.
- Logon as Service Agent.
- Go to the Service work center.
- Go to the Ticket work center.
- Click New.
- Create a new Ticket.
- Result: You did not get automatically maintained as Ticket Owner/ Processor. (However the expected result is that you have been assigned the Ticket automatically).
Cause
This is expected system behavior.
Resolution
To solve this, Adjust the Fine-Tuning Accordingly by setting the Involved Parties for Tickets (this needs to be done separately for Tickets for Customer Support and for Tickets for Employee Support):
- Log on as Administrator.
- Go to the Business Configuration work center.
- Select the Open Activity List button.
- Select the Fine-Tune tab.
- Under Tickets for Customer Support select the Involved Parties fine tuning activity.
- Scroll down until you reach the Processor Party row.
- Select the Processor Party in the table and click Maintain Determination.
- Uncheck all option and only select the last option 'Current User'.
- Check attached screenshot. This would help to achieve the desired behavior that if any ticket is created the current user is then assigned as the processor.
- Adjust Fine-Tuning Accordingly.
Keywords
Ticket, Processor, Current User, C4C , Cloud for Customer , determination , involved parties , current user, direct responsible , assign ticket, auto assign , Hybris , KBA , LOD-CRM-EMP , Employee , How To
Product
Attachments
Processor as Current User.PNG |