SAP Knowledge Base Article - Public

2527693 - Cannot add a Product to an Invoice Schedule in a Contract

Symptom

You are not able to add a product to an invoice schedule in a contract.

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Contracts view.
  3. Click on the New button and select the Contract option.
  4. Enter all respective details.
  5. Navigate to the Items tab
  6. Add a material (item Type Product – contract).
  7. Navigate to the Pricing and Invoicing tab.
  8. Select the Invoice Schedule sub tab.
  9. Click on the Edit Invoicing Time Frame button.
  10. Add Invoicing Time Frame XYZ (XYZ represents the name of the invoicing time frame).
  11. The material does not appear in the the section Available Items for XYZ Timeframe and you can not add the material to the invoice schedule.

Cause

Product items (item type Product – contract) in contracts have to be consumed in a sales order delivery and invoicing process is always done via the sales order and hence it is not possible to add a product with the item type Product – contract in an invoice schedule of a contract.

Please note that in a sales order you are only able to add an invoice schedule for a product with the item type Products - project based. However, since product items in a contract have to be consumed in a sales order as Product - delivery-based it is not possible to use products with item type Products - project based in a contract and hence the product in a contract cannot be added in an invoice schedule of a sales order either.

Resolution

This is the expected system behaviour.

See Also

2527657 - Product is not Added in Sales Order created with Reference to a Contract

Keywords

KBA , migration of contract , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Business ByDesign all versions