SAP Knowledge Base Article - Public

2527717 - Onboarding Employee Notifications not being sent - Onboarding 1.0

Symptom

Candidates are not receiving Onboarding 1.0 notifications.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

  1. Login to Onboarding 1.0
  2. Go to Onboarding 1.0 > Settings > Audit Trail
  3. Find your candidate
  4. Look at his Audit Trail
  5. Notification is not there

Cause

In this article we will cover three possible causes for this issue:

  1. Notification Email template is blank
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  2. The candidate does not meet the condition
    1.png

  3. Notify At is Notification Triggered
  4. Notification Type or CC key has no value
  5. User has no email in Onboarding > Security > Users

Resolution

Notification Email template is blank

  1. Enter an Email Template for the notification by navigating to
  2. Onboarding
  3. Notifications
  4. Search for your notification
  5. Click on it
  6. Select Email on the Navigation
  7. Add and save

The candidate does not meet the condition

  1. To check if the candidate meets the condition
  2. Navigate to Super Admin
  3. Manage HRData search for the candidate
  4. Ctrl + F search for Key in the condition and check what value is in it

Notify At is Notification Triggered

  1. Check in Advanced Conditions
  2. Completed Notification cannot be blank
  3. Add the "Completed Notification" value
  4. Apply and save

Notification Type or CC key has no value

  1. Check if Named User has value in the process (activity)
  2. Certify that the value is being passed in the integration

Note: Named User is a user defined in Super Admin which has users defined. For Example: Named User "HR Manager" is a standart one and has value of userID for the "HR Manager" that was defined in the beggining of the Onboarding process.

User has no email in Onboarding > Security > Users

For this case when notification fail (no "To" recipient) please make sure the user has an email in Onboarding > Security > Users

Keywords

Notification, Not, Trigger, Blank, Template, Advanced, Condition, Onboarding, 1.0, Email, Obd, Onb, Complete, Notify, At, CC, To, Mail , KBA , LOD-SF-OBD-EML , Emails and Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions