Symptom
Customer has set up the integration for LMS External Users. But when registering as a user via the external site you encounter the following error after hitting the 'Submit' button.
"Validation Error - You must correct the following error before proceeding: The registration system is currently experiencing technical difficulties. Please try again later"
Environment
- SuccessFactors Learning Management System (LMS)
- SuccessFactors Learning Management System (PLT)
Reproducing the Issue
- 1. Go to external site
- 2. Click register for new user & fill in all fields
- 3. Click 'Submit' > error is generated
Cause
This is caused by a mismatch of User Credential mandatory fields between Employee Central and LMS.
Resolution
Compare and correct any difference's between mandatory fields in EC using 'Manage Business Configuration' and the External LMS Site configuration.
First Check what is set as Mandatory in Employee Central.
- Log in to BizX
- In the drop down Menu select Admin Centre
- In the Tool Search field type Manage Business Configuration and press enter
- In the left hand menu, select PersonalInfo.
- There is a column marked Mandatory, these are fields that are required for successful registration of a new user.
- Next set these fields are mandatory in LMS External Site.
- Go to BizX and select Admin Center from the Drop down list
- Select Learning Administration from the Menu
- Select System Administration -> Application Administration -> Sites
- Select the Site you wish to edit from the list -> Select User Created Account tab:
- Finally set the relevant fields that are required to be Mandatory to be in sync with the settings with Employee Central -> Click on Apply Changes button.
- Try Registering a User again from the External Site.
- In the case that there is Mandatory fields in Employee Central that do not exist in LMS, you will need to create custom column user fields in LMS
- In LMS, Click on System Administration -> Custom Fields -> User -> Add New
- Create the new user columns - Click Add.
Keywords
validation error, external user, experiencing technical difficulties, LMS, employee central, technical difficulties, The registration system is currently experiencing technical difficulties, User Created Account , KBA , LOD-SF-LMS-EXT , Sites and External Users , LOD-SF-PLT-UM , User Management , Problem