Symptom
Language Adaptations done in the C4C system for data coming from a SAP ERP or CRM System are no reflected in PDFs.
Reproducing the Issue
This behaviour can happen in different work centres which trigger data from an ERP system.
Prerequisite: You translated a field ABC (ABC represents the field's name) to DEF via Language Adaptation.
Example in the Account header:
1. You translate the field ABC in the Account header to DEF via Language Adaptation.
2. Go to the Customers work center.
3. Go to the Accounts view.
4. Search and open any account 123.
Result: You can see that the field ABC is called DEF.
5. Go to Sales Data tab.
6. Click on the Actions button (cog wheel).
7. Select ERP custom factsheet.
Result: The system generetes a PDF and the field ABC was not translated here.
Cause
The Language Adaptations are maintained in the C4C system. The Customer Fact Sheet fetches the data from the SAP ERP or CRM system. This system is not related to the language configuration maintained in C4C. Therefore, the translation is not applied to the Fact Sheet.
Resolution
You can change the templates in the ERP or CRM system in order to call the fields the same way in both systems (ERP and C4C).
Keywords
KBA , SRD-CC , Cross Components , Product Enhancement