SAP Knowledge Base Article - Public

2528713 - Failed to connect to system using Live Data Connection to SAP S/4HANA Cloud Edition via OAuth in SAP Analytics Cloud

Symptom

After completing the configuration to connect to a Live Data Connection to SAP S/4HANA Cloud Edition via OAuth, you get the error: Failed to connect to system in SAP Analytics Cloud (SAC.

In the Chrome Developer tools, the following error occurs:

Request URL:https://customer.region.sapbusinessobjects.cloud/s4hcremotes/CONNECTIONAME/sap/bw/ina/GetServerInfo?sap-client=100&sap-language=EN&timestamp=1504279731839&sap-sessionviaurl=X
Request Method:GET
Status Code:500 Internal Server Error

Environment

  • SAP Analytics Cloud 2017
  • S/4HANA Cloud Edition

Reproducing the Issue

You completed the required steps to use OAuth connections in S/4HANA according to SAP Analytics Cloud Documentation. When you click OK, you receive the error message.

Cause

The Communication Arrangement settings on S/4HANA Cloud (myXXXXXX.s4hana.ondemand.com) are incorrectly set.

Resolution

Logon to your S/4HANA and modify the Inbound Communication to set the Authentication Method to OAuth 2.0.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

Hybris, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Hana Cloud for Planning, EPM-ODS, Cloud for Analytics, C4P, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, HCP, C4A, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJ, BOBJcloud, BOCloud., BICloud, BO Cloud, connecting, conecting, conectando, conexão, modelo, SBOC, SAC, SAP BusinessObjects Cloud, Business Objects, SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem

Product

SAP Analytics Cloud 1.0