Symptom
Users are not able to download courses for offline use with Offline Player. When clicking Download, the users receive the error:
There was an error when downloading the content. Please retry after some time. If the error persists, contact your system administrator
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- User attempts to download content on assigned Item
- An error is returned:
Cause
If the issue is happening for all the users for the same Content, it's likely that the offline file is not present in the content folder
Resolution
If the "Available for Offline Player download" is checked on the content object within the Item, the file path and filename provided in the "URL for offline download" must be correct:
- Search for the Item and access Online Content tab.
- Click on Settings icon (top right corner)
- There you should be able to see the "URL for offline download" when Downloadable is checked for the content that can be played offline within offline player.
- Check the URL to where the content is uploaded
- (Example: https://[LMSInstance].plateau.com/learning/user/onlineaccess/icontent.do?Course=CUSTOM&url=/self-managed/Test/Test_Course/Test1.zip)
- The URL is generated automatically when importing content for offline use (see notes below for more details)*
- Connect to the iContent sFTP server and verify that the file path and file name are correct.
Another option is to use the Import Content Tool, make sure that Enable offline player download is enabled and Create a new learning item with for each content package. After the content is imported and the new item is created, cross reference the newly created Content Object settings and the URL for offline download in the new item.
*Note: For information on importing Content to Enable for offline use, please User Assistance Documentation:
See Also
Keywords
Offline Player, Download, LMS Offline Course, error when downloading the content for offline player , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-OLP , Offline Player , Problem