Symptom
You have migrated the Customers and Contacts data successfully in the system. Upon downloading the Value Conversion of the migrated file, you see that the Target values assigned for Contacts are not in sequence. You want to understand what is the order followed while system assigns the Target values for Contacts.
Reproducing the Issue
Perform migration using the below steps:
- Go to Business Configuration work center
- Select Implementation Projects view or Overview
- Search and Open the activity Migration of Customers
- Select Migrate customers using the migration tool
- Upload the Migration File
- Execute Migration for the respective Migration File with Migration Mode Add new records
- Migration is successful
Download the Value Conversion file as below:
- On the migration tool Show Completed Files
- Select the Completed File and choose Actions->Download Value Conversion
- This will download the value conversion for all the converted IDs for Customers and Contacts which have been already migrated
- Save and open the exported .TRV file
- You will be able to see the Source and Target values
- But the Target value assigned for Contacts are not in descending or ascending sequence of Contact IDs available in the Number Range
Cause
While creating Contact, whatever next available ID exists in the Number Range, that will be used for Contact Internal ID.
Resolution
Internal ID of Contacts are picked from the Number Range maintained in the activity General Business Partners. It is not possible to control the order of assignment of internal IDs in ascending /descending order.
Keywords
KBA , determine the order of assignment , order of assignment of target values , assignment of internal ids , order of assignment of internal ids , SRD-CC-MIG-CNT , Migration: Content , How To