SAP Knowledge Base Article - Public

2529457 - Cannot Define a New Default Customer Role

Symptom

The system is not defaulting the customer role according to the Business Configuration settings.

 "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to the Customer WorkCenter.
  2. Go to the Account View.
  3. Click on New to create a new account.
  4. It is observed that the ROLE field is not defaulted according to the business configurations maintained.

Cause

The field Role will be defaulted based on whether the new account is a customer or a prospect. This specification needs to be made in Prospect field.

The Prospect field could be added through Adaption mode.

Resolution

Maintain the Prospect field through Adaption mode and based on the value of this field and Business configurations settings, the Account type will be defaulted.

Business Configuration can be maintained at:

  1. Under Business Configuration work Center
  2. Implementation Project View
  3. Open Accounts under All Activities
  4. Then navigate to Maintain Customer Roles
  5. Maintain the user specified roles

See Also

Account_Prospect_Role_Croped.pngAccount_Cropped.png

Keywords

Customer, Business Configurations settings, Account, Roles , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions