SAP Knowledge Base Article - Public

2530791 - Reason for Rejection Field Greyed Out in Items Tabs and Also Getting Error While Maintaining Reason for Rejection in Header Level.

Symptom

You are trying to maintain Reason for Rejection at header level and receive the error message, Item XX: You cannot change the data in Reason for Rejection. Refresh the screen and try again. If the problem persists, report an incident. When you check the Line Item XX in Service and Spare Parts tab, the Reason for Rejection field is grayed out.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to work center Service Orders
  2. Go to view Service Order Processing
  3. Edit the Service Order ABC (ABC represents the service order id)
  4. Navigate to Service and Spare Parts tabs
  5. The Reason for Rejection field is grayed out.
  6. Navigate to General tab and there you maintain Reason for Rejection and you receive the error message. 

Item XX: You cannot change the data in Reason for Rejection. Refresh the screen and try again. If the problem persists, report an incident

Cause

The item XX is of Item type service- Time and Material and the corresponding service confirmation is not with status Finished. Therefore the reason for rejection is disabled at Item level.

This item cannot be canceled with open service confirmation.

Resolution

For Item type service- Time and Material, we need to complete the corresponding service confirmation or delete the service confirmation (if service confirmation is with status Not Started) and then you can maintain reason for rejection for the line item at service order.

Keywords

KBA , AP-SVO , Service Order Processing , How To

Product

SAP Business ByDesign all versions