SAP Knowledge Base Article - Public

2531365 - Contact Details Missing When Adding Existing Contact To Account

Symptom

The Contact details such as e-mail id and mobile number are not displayed when you add the Contact to an Account.

Reproducing the Issue

  1. Go to Customers work center.
  2. Go to Accounts view.
  3. Open Account ABC(where ABC is any Account).
  4. Navigate to Contacts facet.
  5. Click on the cogwheel icon.
  6. Select Add to add an existing Contact.
  7. Add the Contact XYZ(where XYZ is any existing Contact).

Deatils such as e-mail id,phone number are not displayed under Contact.

contact rela.png

Cause

You did not maintain any relationship between Account and Contact.A relationship should be maintained explicitly between Account and Contact.
The relationship details should be maintained individually for each relationship, only then the Contact Details will be displayed.

Resolution

  1. Go to Customers work center.
  2. Go to Contacts view.
  3. Open Contact XYZ.
  4. Navigate to Relationships facet.
  5. Click on Add and select Relation type as Is Contact Person for.
  6. From the value help for Business Partner select Account ABC.
  7. Click on Add.
  8. Enter all the details here.

The details maintained here will be displayed in Contacts facet under Account workcenter.

contact_relationshipa.png

Keywords

KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711