SAP Knowledge Base Article - Public

2531625 - Opportunities Are Not Being Synced to the Forecast

Symptom

  • You have created new opportunities that are not being synced to the already created forecast
  • When saving a new Forecast, you receive the message: "No relevant opportunities exist at that time, so you cannot forecast data"

Environment

SAP Hybris Cloud

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Click on the New button.
  4. Enter the relevant data.
  5. Open the opportunity XXX (XXX represents the opportunity ID )and select the Publish to Forecast checkbox.
  6. Go to the Forecasts view.
  7. Open forecast ZZZ (ZZZ represents the forecast ID).
  8. In the Versions facet click the cogwheel icon and select Sync with Opportunities.
  9. Go to the Opportunities facet.

Result: the opportunity XXX has not been synced.

Cause

The newly created opportunity does not match the conditions maintained in the forecast.

Resolution

You need to check if the newly created opportunity has the same conditions maintained as the forecast:

  1. Opportunity with Publish to Forecast flag set to true.
  2. Opportunity start and end dates should fall within the forecast dates.
  3. Opportunity owner should be the same as Forecast owner.
  4. Opportunity Sales Unit should be the same as Forecast Sales Unit.
  5. Opportunity currency needs to be the same as the one in the Forecast.

See Also

Opportunity, Forecast, Save Failed, 

Keywords

KBA , LOD-CRM-FRC , Forecasting , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1708