Symptom
Some PDI fields are not translated to Spanish even though the fields are correctly maintained in Language Adaptation.
Reproducing the Issue
- Log in to the system in Spanish.
- Go to the work center Sales.
- Go to the View Opportunities.
- Select All from the Query dropdown list.
- Open the Opportunity ABC(ABC represents the name of the opportunity).
- Go to the Products Facet.
You will see that the field XYZ and DEF(XYZ and DEF represents the names of the fields displayed) are not displayed in the Spanish Language.
Cause
The reason for the adapted texts not being shown is that the Language Adaptation Spanish (Spanish represents the Language Adaptation example) is outdated.
or
The PDI solution name has changed and the Language Apaptation still shows the collect results that contains the obsolete first solution.
- In this case a solution name change would be the creation of a first time patch resulting in the enabled Original solution becoming disabled
- or a change in the solution enabled
- In a production tenant for example - this would have no bearing since an original solution will only be present there and will not change
Resolution
You must select Collect Texts again and re-do the translations for the new PDI solution.
Keywords
KBA , LOD-CRM-EMP , Employee , How To