Symptom
Admin is not able to search for users via Admin > Users, and when running reports, he also cannot filter by users because searching does not return any results.
Environment
Successfactors Learning Management System (LMS)
Reproducing the Issue
- Log in to LMS as Admin.
- Go to Users tab and do a blank search. No results will be returned.
- Click 'Reports' button.
- Select any report that has User filtering (e.g. User Curriculum Status (CSV)).
- Filter User and do a blank search. No results will be returned.
Cause
The role assigned to the admin has no worklow 'Search User'.
Resolution
Ad the 'Search User' workflow to the admin's role or add a role to the admin that already has this workflow.
To add the workflow to the role:
- Navigate to Admin > System Admin > Security > Role Management.
- Search for the Role ID and edit.
- Go to 'Workflows' tab.
- Click 'add one or more from list'.
- Expand 'Search'.
- Check 'Search User', then click 'Add' button.
To add a role to the user:
- Look for a role that has the 'Search User' and get its Role ID.
- Navigate to Admin > System Admin > Admin Management.
- Search for the Admin ID and edit.
- Go to 'Assigned Roles' tab.
- Click 'add one or more from list'.
- Search and check for the Role ID, then click 'Add' button.
See Also
2419994 - Learning: No result when searching for a user by last name in Schedule Offering
2281598 - How to search for user names with special characters by typing
2229595 - Cannot search for any users on LMS Administration
2465785 - Supervisors criteria on User Search doesn't show all users records
Keywords
Search User, Search, user, worklow, admin, report, filter, result, role , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem