SAP Knowledge Base Article - Public

2532858 - Approval Process Defined by Sales Units is Not Working

Symptom

The approval process for an Object to be defined by Sales Units was created, but it is not being triggered for the desired sales unit.

Environment

SAP Cloud for Sales

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the the desired object, for example, Sales Quotes view.
  3. Click on New.
  4. Enter any account.
  5. Enter sales unit ABC or YYY (ABC stands for the name of the sales unit and YYY for the ID number of the specific unit).
  6. Click on Save and Open.
  7. Click on Actions and then Submit.

Result: The sales quote status is: Approval not Necessary.

Cause

In the Approval Process it was used the Compare Operator of "matches pattern" for condition Sales Unit.

The sales units in the system are of format "YYY - ABC", but in your approval process, the value to compare with "matches pattern" is ABC or YYY (name or ID only).

Resolution

In the approval process condition, enter the value YYY - ABC (ID - name) to use with "matches pattern" operator.

You can just copy the ID and name of the Sales Unit from Org Structures and paste in the approval process condition value.

Keywords

KBA , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP-CO , Lean Sales Orders , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions