Symptom
You encounter error messages when creating a ticket from a sales document (sales quote, sales order or opportunity):
- 'Error in business conf.; item type code not determined; report incident'
- 'Error in business conf.; item type not valid; report incident'
- 'Item XYZ: processing code is not valid. Please check' (XYZ represents the item number).
Environment
SAP Cloud for Customer
Reproducing the Issue
The below steps use sales quote as an example, it also applies to sales order and opportunity.
- Go to the Sales work center.
- Go to the Sales Quotes view.
- Open the quote ABC (ABC represents the sales quote with a product on the item level).
- Go to the Tickets facet.
- Click the New button.
- Following error messages are displayed:
- 'Error in business conf.; item type code not determined; report incident'
- 'Error in business conf.; item type not valid; report incident'
- 'Item XYZ: processing code is not valid. Please check'
Cause
Item processing is not active for tickets in Business Configuration.
Resolution
After maintaining correct settings in Business Conifiguration as per steps below, you should be able to create new ticket without error.
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select relevant project.
- Click Edit Project Scope.
- Go to the Scoping section.
- Expand scoping element: Service > Customer Care.
- Scope the Service and Repair element.
- Save the changes.
See Also
2362178 - You are not Able to Create a Ticket from Sales Order Searched in the ECC Search Work Center
Keywords
Sales Quote, Sales Order, Opportunity, Ticket, Items, Error, Item Type Code , KBA , LOD-CRM , Cloud for Customer , How To
Product
SAP Cloud for Customer add-ins all versions