SAP Knowledge Base Article - Public

2533277 - Errors When Creating Ticket From Sales Document With Items

Symptom

You encounter error messages when creating a ticket from a sales document (sales quote, sales order or opportunity):

  • 'Error in business conf.; item type code not determined; report case'
  • 'Error in business conf.; item type not valid; report case'
  • 'Item XYZ: processing code is not valid. Please check' (XYZ represents the item number).

Environment

SAP Cloud for Customer

Reproducing the Issue

The below steps use sales quote as an example, it also applies to sales order and opportunity.

  1. Go to the Sales work center.
  2. Go to the Sales Quotes view.
  3. Open the quote ABC (ABC represents the sales quote with a product on the item level).
  4. Go to the Tickets facet.
  5. Click the New button.
  6. Following error messages are displayed:
  • 'Error in business conf.; item type code not determined; report case'
  • 'Error in business conf.; item type not valid; report case'
  • 'Item XYZ: processing code is not valid. Please check'

Cause

Item processing is not active for tickets in Business Configuration.

Resolution

After maintaining correct settings in Business Conifiguration as per steps below, you should be able to create new ticket without error.

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select relevant project.
  4. Click Edit Project Scope.
  5. Go to the Scoping section.
  6. Expand scoping element: Service > Customer Care.
  7. Scope the Service and Repair element.
  8. Save the changes.

See Also

2362178 - You are not Able to Create a Ticket from Sales Order Searched in the ECC Search Work Center

Keywords

Sales Quote, Sales Order, Opportunity, Ticket, Items, Error, Item Type Code , KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Cloud for Customer add-ins all versions