Symptom
Item Processing Determination is still occurring, even though the relevant determination rules have been deactivated.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration work center.
- Navigate to Implementation Projects.
- Select your project and click on Open Activity List.
- Search for and open the activity Tickets for Customer Support.
- Open the configuration step Item Processing Determination.
- Observe that all determination rules are marked as Inactive.
- Now, go to the Service work center and navigate to Tickets.
- Open ticket ABC (where ABC is a sample Ticket ID) with Ticket Type = DEF (where DEF is a relevant Ticket Type).
- Go to the Items facet and click Add to create a new item.
- In the Item field, use the value help to select item 123 (where 123 is the Item Code) with Material Type = XYZ (where XYZ is one of the Material Types)
- After selecting the item, the field Processing is automatically determined as XYZ1.
- If you refer back to the determination table from step 5, you will find that XYZ1 is defined as the Processing Code for Ticket Type = DEF and Material Type = XYZ, even though the determination rule is currently inactive.
Cause
Item Processing Determination continues to function even when the rules are marked as inactive.
This is by design, as some customers may require the system to continue applying the previously active version of the determination rules. Therefore, deactivating the rules does not immediately stop the determination logic; the last active configuration is still considered during item processing.
Resolution
We request you to kindly delete the rules if you do not wish the the Item Determination to work when the determination rules are inactive.
Keywords
Item Processing Determination, Rules, Activity List, Ticket, Material Type , KBA , LOD-CRM-EMP , Employee , How To
SAP Knowledge Base Article - Public