Symptom
You want to create new Registered Products or update information on already existing ones using the activity Migration of Registered Products, but the migration template does not contain the fields you require.
Environment
SAP Hybris Cloud for Customer 1711 and higher.
Reproducing the Issue
- Go to the Business Configuration work center.
- Search for Migration of Registered Products.
- Click on Migrate registered products using migration tool.
- Click on 'You Can Also' button on top right.
- Click on 'Download Migration template'.
- You will not find fields such as Sales Organization, Distribution Channel, Division, etc.
Cause
Registered Products are a type of Installation Point, the system contains two separate migration objects (one for Registered Products and one for Installation Points), but they don't serve the same purpose or contain similar fields.
You can migrate Registered Products by using the Migration of Registered Products activity for basic Registered Product information but, in order to migrate complete information or perform updates in fields which are not present in the Registered Products migration template, you should use the activity Migration of Installation Points.
Resolution
To perform the migration of Registered Products, go to the activity Migration of Installation Points in Business Configuration work center and follow the below guidelines to fill the template:
- The field Installation Point ID should be used with the ID for the new Register Product you want to create or with the ID of an already existing Registered Product in the system.
- The Product ID which will be linked to the Registered Product should be maintained in the field Registered Product ID.
- The Serial ID should be maintained in field Registered Product Serial ID.
- To determine you are creating or updating a Registered Product, you should maintain the field Category with value '2', which defines you are creating an Installation Point of type Registered Product.
- In the Installation Points sheet, under Installation Point Details section, the Status field is equivalent of Registered Product Status in UI. If you leave this Status field blank, the system by default, uploads this Registered Product with status In Preparation.
Therefore, it is important to fill the Status field under Installation Point Details section and, not Registered Product Status field in Registered Product Details section.
- In Business Area section of Installation Points tab you can maintain information such as Sales and Service Territory, Sales Organization ID, Distribution Channel Code, Division Code, Sales Office, Sales Group ID, etc.
Note the below points:
- Extension fields added under the section Registered Product: General Information cannot be added to the Installation Point migration template.
Hence this section has been marked as deprecated.
- All the Extension fields should be created under the section Installation Point: General Information.
- The Registered Product migration template has been marked as deprecated as there are many fields in the Registered Product UI which are not available here and there will be no enhancements done to this template.
- All fields of Registered Products are available in the Installation Point migration template (with the exception of Extension fields highlighted in point 1).
- If you want to use all the features of Registered Products in migration template, you have to use the Installation Point migration template.
However if you have created many Extension fields under the deprecated section, for updating these fields you can still use the old Registered Product template. But it is strongly recommended to move these to Installation Point: General Information section if possible. - For all standard fields, the Installation Point template must be used.
Keywords
registered products, migration tool, installation points, how to, modify , KBA , registered products , migration of registered products , installation point , migration of installation points , LOD-LE-IBA-IPO , Installation Point , How To