Symptom
Your user can view Products in the Products work centre, despite having restricted access based on the users' Sales Data.
Reproducing the Issue
- Open the Products work centre.
- Select the Products view.
- You can view Restricted Products that do not belong to your assigned Sales Organization.
Cause
This is currently the expected system behaviour in Cloud for Customer. It is only after the Product itself is opened, that the Products' content will be blocked.
Resolution
Our development team have identified the root cause and they have added it to the roadmap to be addressed in a future release.
A work around is if the WorkCentre view Product Administration is working correctly for the customer's data, then this can be assigned to the users, and separate the access rights by providing read-only and editable rights to the corresponding users.
Keywords
KBA , LOD-CRM-ACC , Account , Product Enhancement