SAP Knowledge Base Article - Public

2534624 - Field cannot be configured differently in CSF-Succession and Succession Data Model

Symptom

  • Error On Save In Manage Business Configuration: "Data Model is not consistent: For Element : jobInfo the fields : [country-of-company] cannot be configured differently in CSF and Data Model"
  • Error on importing Country/Region Specific Succession Data Model in provisioning: "Form data is invalid com.successfactors.hris.api.exception.HrisDataModelException: Referenced display order follows field(s), employee-class : jobInfo_USA.flsa-status , ; ,should have been configured in DataModel."

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Successfactors Employee Central- Manage Business Configuration

Reproducing the Issue

Scenario 1:

  1. Make any changes in the Manage Business Configuration(BCUI) and save or import a Succession Data Model.
  2. An error comes up as below:

"Data Model is not consistent: For Element : jobInfo the fields : [country-of-company] cannot be configured differently in CSF and Data Model"

Scenario 2:
Note: Above data validation has been automated in Manage Business Configuration, as it will allow the field to be enabled/disabled but it will automatically set the visibility of the field to match other country/region sepcific field. Therefore, above validtion message cannot be seen any more from Manage Business Configuration (BCUI) tool.

  1. Go to provisioning.
  2. Try to import Country/Region Specific Succession Data Model XML which has jobInfo_USA field (in this example: field ID flsa-status). having visibility = "both".
  3. Observe the error: "Form data is invalid
    com.successfactors.hris.api.exception.HrisDataModelException: Referenced display order follows field(s), employee-class : jobInfo_USA.flsa-status , ; ,should have been configured in DataModel."
  4. Go and check succession data model the field id flsa-status is present in it.

Cause

  • Scenario 1: This is due to an invalid configuration in either Succession Data Model or Country Specific Succession Data Model. The country-of-company configuration should match in both the 'Succession Data Model or Country Specific Succession Data Model'
  • Scenario 2: The field id attribute is having different properly for example: visiblity = "none". In this example, field jobInfo.flsa-status in Succession Data Model was present but with visibility = "none" but the Country/Region Specific Succession Data Model that was being imported in provisioning had this jobInfo_USA.flsa-status field being imported with configuraiton visibility = "both".

Resolution

  • Compare the field 'country-of-company' in Succession Data Model and Country Specific Succession Data Model. Make sure the configuration is exactly same(including the attributes like visibility, allow-import etc.) in both the data models.
  • This check can also be done from the Manage Business Configuration(BCUI) by comparing the field properties of the field 'country-of-company' in 'jobInfo' section as well as the the country specific sections.
  • To check the data model, please reach out to your partner(if avaialble) else reach out to SAP Product Support by raising an case.

NOTE: As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner. If you're no longer working with an implementation partner, contact SAP Cloud Support.

NOTE: In provisioning during data model import if you encounter this form validation error for the "should have been configured in DataModel."

 Customer Action:

  • As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner. If you're no longer working with an implementation partner, contact SAP Cloud Support.
  • Customer must provide a written approval for (check the data model and the job "Synchronize Business Configuration" is in Submitted state in Provisioning - Setting Up Jobs in Provisioning)

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide -Implementing and Managing Business Configuration (BCUI)

See Also

  • 2080620 - How to enable Manage Business Configuration UI (BCUI) - EC
  • 2324339 - Manage Business Configuration UI (BCUI) is locked
  • 2394286 - Manage Business Configuration: Application Error when trying to save any element in Manage Business Configuration (BCUI)
  • 2478776 - Create New UI Config not available in Manage Business Configuration UI (BCUI)
  • 2458964 - Synchronise Business Configuration Job Failing due to Unknown Error (Error getRoleIdsRuleIdsMap for baseUserId)
  • 2534624 - Error On Save In Manage Business Configuration

Keywords

Data Model, Succession Data Model, Country Specific Succession Data Model, Data Model is not consistent, country-of-company, [country-of-company] cannot be configured differently in CSF and Data Model, Manage Business Configuration, BCUI, should have been configured in DataModel, fields cannot be configured differently in CSF and Data Model , KBA , should have been configured in datamodel , cannot be configured differently in csf , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors HCM Core 1708