Symptom
You created a survey to be attached to visits based on a routing rule. However, when you create a new visit, the survey does not get automatically attached.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Surveys work center.
- Go to the Surveys view.
- Create a survey with the category Checklists.
- Go to the Activity Planner work center.
- Go to the Plans view.
- Create an activity plan with Mandatory and Assign Automatically checkbox checked.
- Add the previously created survey to this activity.
- Go to the Routing Rules view.
- Create a routing rule.
- Add the earlier created activity plan to this routing rule and add the following condition:
- Field: Document Type.
- Compare Operator: Equal to.
- With: Value.
- Visit. - Create a visit.
- Open the new visit and go to Surveys facet.
- Click on Actions -> Refresh Visit.
Result: No survey is added to this visit.
Cause
This is expected system behavior, if you have maintained a document type as condition.
Please use the document type Appointment instead of Visit.
In general, the condition for document type is not mandatory.
Resolution
- Go to the Activity Planner work center.
- Go to the Routing Rules view.
- Create a routing rule.
- Add the earlier created activity plan to this routing rule and change the condition as follows:
- Field: Document Type.
- Compare Operator: Equal to.
- With: Value.
- Appointment. - Save it.
Keywords
survey attachment, automatic survey attachment, survey in visits , KBA , LOD-CRM-ACT-VST , Visit Planning , How To
Product
SAP Cloud for Customer add-ins all versions