SAP Knowledge Base Article - Public

2534818 - Survey Does Not Get Automatically Attached to Visits

Symptom

You created a survey to be attached to visits based on a routing rule. However, when you create a new visit, the survey does not get automatically attached.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Surveys work center.
  2. Go to the Surveys view.
  3. Create a survey with the category Checklists.
  4. Go to the Activity Planner work center.
  5. Go to the Plans view.
  6. Create an activity plan with Mandatory and Assign Automatically checkbox checked.
  7. Add the previously created survey to this activity.
  8. Go to the Routing Rules view.
  9. Create a routing rule.
  10. Add the earlier created activity plan to this routing rule and add the following condition:
     - Field: Document Type.
     - Compare Operator: Equal to.
     - With: Value.
     - Visit.
  11. Create a visit.
  12. Open the new visit and go to Surveys facet.
  13. Click on Actions -> Refresh Visit.

Result: No survey is added to this visit.

Cause

This is expected system behavior, if you have maintained a document type as condition.

Please use the document type Appointment instead of Visit.

In general, the condition for document type is not mandatory.

Resolution

  1. Go to the Activity Planner work center.
  2. Go to the Routing Rules view.
  3. Create a routing rule.
  4. Add the earlier created activity plan to this routing rule and change the condition as follows:
     - Field: Document Type.
     - Compare Operator: Equal to.
     - With: Value.
     - Appointment.
  5. Save it.

 

Keywords

survey attachment, automatic survey attachment, survey in visits , KBA , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer add-ins all versions