Symptom
We are trying to add some test users via UI for Iteration- but we are getting an error.
When we attempt with CSV import the system is not updating any user - reporting the following error on a single user each time.
Wrapped Exception: Exception caught: [key=Cannot initialize bean because Object Definition is found to be null for object type: Person, values=[]];
Environment
Employee Profile
Reproducing the Issue
1) Via UI -
Enter user details and save > an error is thrown
2)Via Import
Upload prepared user file > no errro on validation > the file import without error however the email report indicate the following:
Wrapped Exception: Exception caught: [key=Cannot initialize bean because Object Definition is found to be null for object type: Person, values=[]];
if you remove the mentioned user in the error report form the user file, and re-upload, the same error is reported but with another user and so on.
Cause
"Enable EP on MDF" is ticked in Provisioning
Resolution
Access Provisioning
Search "Enable EP on MDF" - if this is checked, uncheck this. Your issue should be fixed there after.
a) Manage user should definitely be fixed
b) If you still encounter issue while importing, please do the following:
1-Add a number of users via UI (as this should be working now)
2-Export these users (you get a UDF file)
3- Remove admin users from the UDF file
4-Re-Import the UDF file exactly as downloaded
if the file import correct without error, then, at this point your issue is data related
Ensure that you have enterred all correct data (by filling all fields as in the UDF file previously downloaded)
The reason for such steps when importing more information is required compared to when adding via UI.
c) If "Enable EP on MDF" is not checked please proceed with the b) above
If this does not fix your issue please raise a support case
Keywords
Enable EP on MDF, Manage Users, Import User, Wrapped Exception. , KBA , LOD-SF-PLT , Platform Foundational Capabilities , Problem