Symptom
You are able to create a sub-ticket for an already closed ticket although it is not possible to close a ticket if a sub-ticket is still open.
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open any Ticket with the status Closed.
- Go to the Sub-Tickets facet.
- Click New to create a new Ticket.
Result: The system allows you to create this ticket.
Cause
While you cannot close a ticket which has an open sub-ticket, it is possible to create a new ticket and relate it to a closed ticket. When there are open sub-tickets the system presumes that the main issue has not been solved due to the underlying sub-tickets not being confirmed - the presumption is that the issue is not solved. However, the system allows for you to create sub-tickets after you closed your main ticket and allows for you to carry on working on this issue.
Resolution
This is expected system behaviour.
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , How To