Symptom
You have added a Product/Part that is not available in the stock of your ERP in a Ticket in C4C and the system allows you to add it with no warning/error message.
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
Scenario 1:
- Go to the Service work center.
- Go to the Tickets view.
- Open a Ticket ID ABC (ABC represents the ID of the Ticket).
- Go to the Products facet.
- Add a Product that is not available in stock of ERP.
- System allows you to add this Product without warning/error message.
Scenario 2:
- Go to the Service work center.
- Go to the Tickets view.
- Open a Ticket ID ABC.
- Go to the Parts facet.
- Select More > Add from Stock Location.
- Select Stock Location Name DEF.
- In field Quantity Used, add a Part with quantity larger than available in stock of ERP.
- System allows you to add this Part without warning/error message.
Cause
Currently having a validation between Tickets in SAP Hybris Cloud for Customer and stock in ERP is not supported.
Resolution
This is the system expected behavior.
If you need a warning/error message for this scenario, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
- If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer
Keywords
Product, Part, Stock, ERP , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To