SAP Knowledge Base Article - Public

2536029 - System Allows to Add Products Without Stock in Tickets

Symptom

You have added a Product/Part that is not available in the stock of your ERP in a Ticket in C4C and the system allows you to add it with no warning/error message.

Environment

SAP Hybris Cloud For Customer

Reproducing the Issue

Scenario 1:

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open a Ticket ID ABC (ABC represents the ID of the Ticket).
  4. Go to the Products facet.
  5. Add a Product that is not available in stock of ERP.
  6. System allows you to add this Product without warning/error message.

Scenario 2:

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open a Ticket ID ABC.
  4. Go to the Parts facet.
  5. Select More > Add from Stock Location.
  6. Select Stock Location Name DEF.
  7. In field Quantity Used, add a Part with quantity larger than available in stock of ERP.
  8. System allows you to add this Part without warning/error message.

Cause

Currently having a validation between Tickets in SAP Hybris Cloud for Customer and stock in ERP is not supported.

Resolution

This is the system expected behavior.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Product, Part, Stock, ERP , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1708