SAP Knowledge Base Article - Public

2536440 - On Adding New Relationship in the Relationship Facet of an Account, This Change Does not Show Within the Changes Facet

Symptom

On adding New Relationship in the Relationship facet of an Account, this change does not show within the Changes facet.

Environment

SAP Cloud for Customer

Business by Design

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Search for an account ABC (where ABC is the account name) and open it .
  4. Go to the Relationships facet, click on Add button to add New Relationship Type and Save the changes.

You can see the New Relationship Type as PQR (where PQR is Relationship Type Name) is added.

  1. Go to the Changes facet .

There is no record related to Relationship Type as PQR been added.

Please note: Same behavior with Individual Customers.

Cause

For some data like Sales Data or Relationships we do not write changes for the initial creation. This is mainly done to reduce the data volume of the change-history storage because if an object is newly created you can see the data in the UI and entries in change history would be redundant.

Resolution

This is an expected system behavior.

Keywords

Account; C4C; Individual Customer; Customer; Relationships; delete; Changes; ByD; , KBA , SRD-FIN-TAX , Tax Management , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions