SAP Knowledge Base Article - Public

2536603 - Document Routing Notification and Document Completed Notification are not sending to next Approver - Recruiting Management

Symptom

The Document Routing and Document Completed notifications are not sending when approving or completing the approval of a job requisition.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Approve Job Requisition/Offer etc.
  2. Send to Next Step
  3. Approver does not receive notification

Cause

Common causes of this issue:

Scenario 1: The Originator is the next approver of the requisition.

Scenario 2: Notification template is not configured for all languages.

Scenario 3: Both Document Routing Notification and Document Routing Step Exit Notification are enabled.

Scenario 4: The specific requisition template has not been enabled in "Customize Settings for Form Templates"

Resolution

Scenario 1: The Originator is the next approver of the requisition

Since the Originator is the next approver of the requisition, the system will no longer send a Document Routing Notification as the next approver can immediately approve the requisition upon creation.

This is an expected behaviour.

Scenario 2: Notification template is not configured for all languages.

In E-Mail Notification Templates Settings > Document Routing Notification, check all languages for the templates you are facing an issue with the emails not being sent.

Remove Warning Message by selecting Save Changes below the template box.

 

Document Routing Notification.png

PLEASE NOTE: The resolution also works when Document Due Notification is not triggered.

Scenario 3: Both Document Routing Notification and Document Routing Step Exit Notification are enabled.

E-Mail Notification Templates Settings > Disable 'Document Routing Step Exit Notification'

Our Engineering Team confirmed that, as per the code, Document Routing Step Exit Notification takes precedence over Document Routing Notification. This means that when both notifications are enabled they could come into conflict and not be triggered as expected.

Scenario 4: Ensure that the requisition template is enabled in "Customize Settings for Form Templates":
CustomizeSettingsForFormTemplates.png

See Also

Keywords

Routing email not sending, not being received, Not triggering , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions