Symptom
You have created an Activity plan to assign tasks to a Visit for an Account. The tasks from the Activity plan are not assigned to this Visit.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Open the Account ABC (ABC represents the Account's ID).
- Go to the Visits tab.
- Create a new Visit.
- Tasks are not assigned.
Cause
- These tasks are already assigned to this Account. That means you have another open visit for this account and the tasks are assigned there. Since the tasks in the activity plan have frequency Once, it will not assign the tasks to this new visit, as the old one is still open. OR
- The Activity Routing Rule the triggers the Activity Plan was created with an Organizational Unit different than the account of the Visit.
Resolution
For cause 1:
- You should either cancel or complete the old visit.
- Go to the Customers work center.
- Open the account 123.
- Go to Visits tab.
- Complete/Cancel the open visit.
If there are still open tasks, they will be automatically assigned to the new open visit.
For cause 2:
Create an Activity Routing Rule with not Organizational Unit defined or with the Account ABC's Organizational Unit.
Keywords
Tasks Visits Survey Activity Plan Activity Routing Rule , KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions