Symptom
-
Error: CExtToolBar::GetRemoteFileCookie()
- Fail to logon to an SAP BW System in Crystal Reports.
- Was able to successfully connect to the SAP BW System in older version of Crystal Reports.
- When attempting to connect to the SAP BW System 7.01 from Crystal Reports designer, it fails with the error like:
CExtToolBar::GetRemoteFileCookie() HR = 0x80040154
CExtToolBar::InitOpenSaveDialog() HR = 0x80040154
CExtToolBar::InitializeGlobalData() HR = 0x80040154
Environment
- SAP Crystal Reports 2013 - Support Pack 05 and above
- SAP Crystal Reports 2016
- SAP BW 7.01
Reproducing the Issue
-
Install the SAP Logon and BEx Tools on a local computer.
- Open Crystal Reports designer.
- In Crystal Reports, under the menu "SAP", select "Create New Report from a Query...", or "Open Report..."
- In the "SAP Logon" window, select the SAP BW 7.01 System, and click "OK"
It then fails with an error like:
CExtToolBar::GetRemoteFileCookie() HR = 0x80040154
CExtToolBar::InitOpenSaveDialog() HR = 0x80040154
CExtToolBar::InitializeGlobalData() HR = 0x80040154
Cause
-
The SAP BW System 7.01 version was lower than SP16.
- Crystal Reports does not support connecting to SAP BW 7.01 lower than SP16. For reference, see the supported platform document.
Resolution
-
Update the SAP BW System 7.01 to SP16 or higher.
Keywords
CR, SAP BW 7.01, Crystal Report , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016