Symptom
You would receive an application error when Rehiring an inactive user
The application error id would be accompanied by: The employee has been marked as Not Ok to Rehire, please update employee details to rehire
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central - Hire / Rehire
Reproducing the Issue
- Go To Rehire inactive user
- Rehire
- Result: The employee has been marked as Not Ok to Rehire, please update employee details to rehire
Cause
Based on the latest system behavior, transactions for terminated/inactive users with “Ok To Rehire” = No will not be saved.
- When you click on “Save” after completion of Compensation Information portlet in the rehire process if there is no workflow.
- When the final approver tries to approve the rehire workflow if a workflow is involved.
Resolution
If there is an existing Rehire workflow, as a solution, please withdraw/reject the current workflow if it's there. Change “Ok To Rehire” = Yes for the terminated employee in his Termination Details record and reinitiate the rehiring process.
If there is no Workflow, then you need to update the Termination Details and set the value to Yes.
Note:
The validation is currently expected to occur at the final save of the Rehire. We have an open enhancement to change this behavior, however we do not yet have an exact timeline as when this will be deployed/enhanced for a specific version.
Keywords
Termination, Ok To Rehire, Separation, ECT-52341, The employee has been marked as Not Ok to Rehire, please update employee details to rehire,employment detail , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC , Employee Central , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem