SAP Knowledge Base Article - Public

2540067 - Warranty Field is Missing from Web Service "ManageRegisteredProductIn"

Symptom

Standard field Warranty is missing from Web Service ManageRegisteredProductIn.

Reproducing the Issue

  1. Go to Products workcenter.
  2. Select Registered Products view.
  3. Open any Registered Product and find the standard field Warranty.
  4. Go to Application and User Management workcenter.
  5. Select Service Explorer view.
  6. Search for ManageRegisteredProductIn and download the WSDL file.
  7. The Warranty field is missing.

 

Cause

The Warranty ID which is an External ID can only be viewed and not the Internal Warranty ID in this WSDL file.

Resolution

  1. Go to Application and User Management workcenter.
  2. Select Communication Arangement workcenter.
  3. Search Registered Product And Installation Point Replication From External System.
  4. Download the WSDL file.

Note: There is corresponding migration template for this web service - Migration of Installation Points.

In this migration template there is a field which corresponds to the C4C Warranty ID : Registered Product Warranty ID.

 

Keywords

Warranty Field is Missing, Warranty, ManageRegisteredProductIn , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Problem

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808