Symptom
Customer is trying to rehire an inactive employee but is receiving an application error when submitting the employee.
Environment
SAP SuccessFactors Employee Central - All Versions
Reproducing the Issue
- Go to Admin Center
- Search for Rehire Inactive Employee
- Select the employee you need to rehire
- Complete all the required fields
- Click Submit
- You will get an application error and cannot save the information
Cause
There are two possible causes:
- The employee has duplicated Time Accounts;
- It may have an overlapping of Time Accounts validity dates;
Resolution
- Go to Admin Center;
- Search for Import and Export Data;
- Select Export;
- Select Time Account without dependencies;
- Go to Monitor Job to download the file this export will generate;
- Save the file in your computer and filter it by the user id of the employee you are trying to rehire;
- If you find duplicated Time Account:
Please Delete the duplicated time accounts;
- If you find time accounts for this user where end date is after the rehire date, this means that the account has overlapping periods;
In case you find time accounts with overlapping periods you need to correct the validities please refer to the KBA 2309405;
Example:
See Also
2540832 - Time Off Balance Is Not Reset When An Employee is Rehired
Keywords
Employee Central, Rehire, Application Error, Time Off, Time Account, Rehire an inactive Employee, TIME_ACCOUNT_ALREADY_EXIST, BOOKING_PERIOD_CANNOT_BE_REDUCED_BY_SYSTEM , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem