SAP Knowledge Base Article - Public

2540478 - Application error in Rehire - Invalid Time Account

Symptom

Customer is trying to rehire an inactive employee but is receiving an application error when submitting the employee.

Environment

SAP SuccessFactors Employee Central - All Versions

Reproducing the Issue

  1.  Go to Admin Center
  2.  Search for Rehire Inactive Employee
  3.  Select the employee you need to rehire
  4.  Complete all the required fields
  5.  Click Submit
  6.  You will get an application error and cannot save the information

Cause

There are two possible causes:

  1. The employee has duplicated Time Accounts;
  2. It may have an overlapping of Time Accounts validity dates;

Resolution

  1.  Go to Admin Center;
  2.  Search for Import and Export Data;
  3.  Select Export;
  4.  Select Time Account without dependencies;
  5.  Go to Monitor Job to download the file this export will generate;
  6.  Save the file in your computer and filter it by the user id of the employee you are trying to rehire;
    1.  If you find duplicated Time Account:

Please Delete the duplicated time accounts;

    1. If you find time accounts for this user where end date is after the rehire date, this means that the account has overlapping periods;

In case you find time accounts with overlapping periods you need to correct the validities please refer to the KBA 2309405;

Example:

2017-09-26_17-15-31.png

See Also

2540832 - Time Off Balance Is Not Reset When An Employee is Rehired

Keywords

Employee Central, Rehire, Application Error, Time Off, Time Account, Rehire an inactive Employee, TIME_ACCOUNT_ALREADY_EXIST, BOOKING_PERIOD_CANNOT_BE_REDUCED_BY_SYSTEM , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem

Product

SAP SuccessFactors Employee Central all versions