SAP Knowledge Base Article - Public

2540622 - Tags appear around spaces, line breaks and special characters in Print Preview of rich text editor field

Symptom

You see tags on the print form generated from rich text editor field

Reproducing the Issue

1. Login to system.

2. For example, go to Sales workcenter.

3. Navigate to Opportunities.

3. Open any Opportunity.

4. Click on Action button and select Preview.

5. PDF document opens.

6. Tags appear in the PDF document generated.

Cause

In the Form Template maintained for opportunities, the Field Format for the Rich Text Editor field has been maintained as ' Plain Text Only'.

Resolution

 Update the Field Format of the Rich Text Editor field in the Form Template to 'Rich Text'. This would allow text in the Rich Text Editor field to appear correctly on the printed form.

Keywords

KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Hybris Cloud for Customer add-ins 1708