SAP Knowledge Base Article - Public

2541091 - Imported Data in Data Workbench Does not Appear in the System

Symptom

When using Data Workbench to import new data to the system, the import runs successfully, however the data cannot be found in the system afterwards.

Reproducing the Issue

  1. Go to the Data Workbench work center.
  2. Navigate to the view Import.
  3. Select the required business object and execute the import normally.
  4. Go to the Monitor view of the work center.
  5. The uploaded file should have all records imported without errors.

When checking in the respective business object UI, the imported records cannot be found.

Cause

This issue occurs because a deliberate blank (" ") space was provided in the data workbench import file for the External Key field.

For some import operations, the External Key value is not mandatory in Data Workbench, however it cannot have a blank space as a value.

Resolution

Make sure that the import file does not contain blank spaces as values for the field External Key.

In order to confirm this, open the file in a pure text editor and verify the External Key field.

Keywords

KBA , LOD-CRM-INT-DWB , Data Workbench , How To

Product

SAP Hybris Cloud for Customer add-ins 1708