Symptom
You wish to remove options from within the Party Role drop down menu on the Account Team facet.
Environment
- SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Account view.
- Open any Account.
- Go to the Account Team facet.
- Select Add.
- In the drop down menu for the field Party Role you see several values, some of which you would like to remove.
Result: You find no option to remove any of the values.
Cause
This is expected system behaviour.
Resolution
You can restrict values by setting up a Code List Restriction.
You must have administrator authorizations to perform these actions:
- Go to the Administrator Work Center.
- Go to the General Settings view.
- Select Code List Restrictions.
- In the New Code List Restriction dialog screen, select the following:
-The Business Object for which you want to restrict certain code types.
-The Code to Restrict that is the code that you want to restrict for the business object. You can select from the code values that are displayed for the selected code type of the business object.
-The Business Role for which you need to impose this restriction.
-Control Fields: Additionally, apart from business object and code types, you can also choose to maintain restrictions for individual control fields. You must specify if these control fields are business or extension fields. The selection values will be displayed accordingly. - Save your entries.
Keywords
C4C, Cloud for customer , Code List Restriction, Account, customer , code types , business objects , general settings , administrator, account team, facet , view, work centre, party role, drop down , option , sales , service , KBA , LOD-CRM-SRP , Service Request Processing , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions