Symptom
Ratings appear as N/A when rating source is defined as Employee Profile.
**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**
Environment
SAP SuccessFactors Compensation Management
Reproducing the Issue
- Log in as someone with sufficient privileges to view the trend portlet
- Go to Employee Files
- Look for a specific user
- Verify Performance Portlet displays rating.
- Next, Navigate to Compensation and select the worksheet. Observe that ratings appear as N/A.
- Check Rating Source by navigating to Admin Center->Compensation Home->Open Template->Plan Setup->Plan Details->Rating Source->It's set to Employee Profile.
- Your Product Support Specialist or Consultant has already confirmed that the start date for the relevant portlet has been set to visibility="edit" (see KBA 693864 - All about Employee profile as rating source in a Compensation Template - Compensation)
Cause
The trend information that was used for the Employee Profile rating source has a start date that is set after the effective date set on the rating source.
Resolution
To correct this issue, the start dates of the ratings must be set to before the effective date of the rating source. You can choose to either:
- update the trend information blocks using Import/Export Extended User Information and set the start-dates to before the form's effective date; or
- update the effective date under Compensation Home > Plan Setup > Plan Details > Rating Sources. NOTE: this solution requires deleting all active worksheets for the template in order to save changes
See Also
Keywords
pmrating, employee profile, sysoverallcustom1, sysoverallcustom2 , KBA , LOD-SF-CMP-ADM , Admin Tools, Settings, Permissions , Problem