Symptom
Profile portlets that contain attachment fields show the following error: "There were problems getting attachment data".
Environment
SuccessFactors Employee Profile
Reproducing the Issue
Go to Employee Profile/People Profile and verify that there are attachment fields showing as "There were problems getting attachment data"
Cause
This is caused by importing portlet data of a portlet that has attachment fields using "Importing Extended User Information", with overwrite option.
Resolution
Fields with attachments can only be imported through a backend job, so that the files can be taken from the SFTP Server. In case they are imported on the Admin Center, only the text fields present on the .csv will be kept, and the attachments will be removed, causing this issue.
Keywords
Attachment Block, PP3 Attachment Error , KBA , LOD-SF-EP-BGD , Background Elements , Problem