SAP Knowledge Base Article - Public

2543156 - Phone Number Field Contains Alphabetic Characters

Symptom

You are able to save Alphabets in Phone Number field.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers work center.
  2. Go to Accounts view.
  3. Open Account 123(123 is the Account Id).
  4. Click Edit.
  5. In the Phone field, enter alphabetic letters for example: ABCDEFGHIJ.
  6. Save the changes.

The Phone number is saved successfully and the system does not throw any error or warning.

Cause

The Alphanumeric or Alphabetical values are valid and indeed required in some cases.

Especially in US, Alphanumerical Phone Numbers have established as they are more convenient to remember and could have a better recognition value than Numerical ones.
For example: A Customer support number could be advertised as follows:
Alpha: 0040-CUSTSUPPORT
Numerical: 0040-28787877678

The system only checks the entry for special characters such as "<>.,!§% &(@€". If you enter these characters the system will remove them from the telephone-number field as they are not valid.

Alphanumeric values will remain in the field as they are valid components of Phone Numbers.

Resolution

The is the expected System behavior.

See Also

Blog: SAP Cloud for Customer Phone Number Parsing and Formatting

Keywords

telephone, phone, mobile, number, alphabet, letter
, KBA , phone , mobile , alpha , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions