Symptom
You have set up the server-side Integration for Outlook C4C, but you are getting errors when trying to do any activity with the addin.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
[Pre-requisites:
- You have licensed your system to use Server-side Integration for MS Outlook.
- You have provisioned Key Users to activate business Users.
- You have followed the documentation and setup Server-side integration in your system. ]
Steps:
- Go to Outlook.
- In the Home tab the View Context of SAP Hybris Cloud for Customer button is greyed-out:
- While performing a sync, you get some error like "Something went wrong. Please reload".
.
Cause
There might be several reasons why these errors might occur. Please follow the troubleshooting steps below.
Resolution
Instructions
a) Make sure the add-in is installed by verifying its status in C4C:
- Go to Email Integration
- In the Groupware Settings select Users.
- Find the affected user and press the gear icon on the top right.
- Press Check Add-in status.
b) Result should be the following:
c) Log-on to the OWA Exchange server or open the Office 365 account in a web browser. Make sure the add-in is loading successfully.
- If add-in works in OWA, but doesn't load in Outlook - check the current Outlook version and make sure the most recent updates are installed. Refer to additional information on Microsoft page about versions http://social.technet.microsoft.com/wiki/contents/articles/31133.outlook-and-outlook-for-mac-update-file-versions.aspx#A.
- Try installing any other free add-in from Office store and check, if it works.
- Sometimes changes to add-in commands, such as the icon for a ribbon button or the text of a menu item do not seem to take effect. Clear the Office cache of the old versions. Delete the content of folder %LocalAppData%\Microsoft\Office\15.0\WEF (for Office 2016 it would be 16.0) and restart Outlook.
- Internet Explorer security settings might also be related to the issue (if add-in fails to load). Steps to proceed:
- In Internet Explorer, click the Tools button, and then click Internet Options.
- Click the Security tab, and then select the Internet Sites Zone.
- Select the Enable Protected Mode check box, and then click OK.
- Restart Internet Explorer and Outlook, check if the issue persists.
- If it didn't work, enable Protected mode on Restricted Zone and try.
- If nothing works, please raise an Incident to Revenue Grid Development team.
Keywords
Server-side, Outlook, Error, reload, addin error, Server-side Integration, popup , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To