Symptom
You have added a Contact to an Opportunity that is not related to the account of the Opportunity. In the Contacts facet, the address data is only displayed for Contacts that are related to the Account.
Reproducing the Issue
1. Go to the Sales workcenter.
2. Go to the Opportunities view.
3. Go to the Contacts facet.
4. Click Add to add a Contact.
5. Click the value help symbol for the name.
6. Select All and select a contact that is not related to the account (you see the address data in the search).
7. Add this Contact to the Opportunity.
Result: the address data is not displayed in the Contacts facet. However, for a contact that is related to the account, the address data is shown.
Cause
If a Contact is not related to an Account, then only the private address is displayed, if applicable.
Resolution
This is the expected system behaviour. This logic cannot be changed as it would be incompatible for other customers.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To