Symptom
System allows user to enter the team which is not in master data.
Reproducing the Issue
- Go to service work center.
- Choose the view tickets.
- Find ABC (ABC represnet ticket id)
- Go to edit mode.
- In the filed Agent choose the value help.
- Enter any random value that does not exist in master data.
- Choose save.
- System allows to save the data with error message "please enter valid object ID".
Cause
Ticket Object allows saving of non-existing master data reference like product, team, agent...etc.
Resolution
This is standard and expected behavior.
Keywords
KBA , SRD-CC , Cross Components , How To
Product
SAP Hybris Cloud for Customer add-ins 1708