Symptom
You are trying to create a service ticket, but it does not give the option to select a Customer and Contact. You can only select Partner or Partner Contact.
Reproducing the Issue
- Go to Service work center;
- Then go to Tickets view;
- Click on New;
- You can see that the system does not show the option to add a customer account;
Cause
This is the expected system behavior. This is occuring because the you have both work center views 'Employee Support' and 'Customer Service'. This is not recommended setup.
Resolution
The business user responsible for customer service must not have the Employee Support work center and work center views assigned.
To solve the issue, you need to remove work center Employee Support under work center Service, then the fields related to customer account will be displayed.
Keywords
KBA , customer account , ticket , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , How To